Pré-visualização do CLEUR! Fonte de automação de rede orientada pela verdade

Pré-visualização do CLEUR! Fonte de automação de rede orientada pela verdade

Pré-visualização do CLEUR! Fonte de automação de rede orientada pela verdade
cupom com desconto - o melhor site de cupom de desconto cupomcomdesconto.com.br


É um novo ano e uma nova década, então é hora de um NOVO BLOG sobre automação de rede. Estou me preparando para o Cisco Live Europe 2020 e quero dar a todos uma prévia do que falarei na minha sessão Como o DevNet Sandbox construiu uma rede automatizada de datacenter em menos de 6 meses – DEVNET-1488. Se você estiver em Barcelona, ​​registre-se e junte-se a mim para ver como abordamos este projeto com o objetivo de “inovar até o ponto de pânico” e trazer muitos novos processos de automação de rede e NetDevOps. Mas não se preocupe se você estiver lendo isso de longe no futuro ou não estiver participando do CLEUR, este blog ainda será muito divertido e útil!

Nos últimos blogs, falei um pouco sobre automação baseada em serviços de rede (parte 1 e parte 2), e no blog de hoje eu quero aproveitar aqueles mostrando de onde vêm os detalhes que fornecem o INPUT à automação – algo geralmente chamado de Fonte da Verdade.

Fonte de automação baseada na verdade

Se você está navegando pelo espaço de automação de rede há algum tempo, pode ter se deparado com esse termo … ou talvez não esteja, então deixe-me explicar melhor.

Digamos que você esteja mergulhando em um projeto para automatizar a configuração da interface dos seus roteadores. Você precisará de duas coisas (provavelmente mais de duas, mas, para esse argumento, abordaremos duas).

Primeiro, você precisará desenvolver o “código” que aplica os padrões desejados para a configuração da interface. Isso geralmente inclui a criação de algum modelo de configuração e lógica para aplicar esse modelo a um dispositivo. Esse código pode ser Python, Ansible ou alguma outra ferramenta / linguagem.

Segundo, você precisa saber quais interfaces precisam ser configuradas e as especificidades de cada interface. Isso geralmente inclui o nome da interface (por exemplo, Ethernet1 / 1), informações do endereço IP, descrições, velocidade / frente e verso, modo da porta do switch e assim por diante. Essas informações podem ser armazenadas em um arquivo YAML (um caso comum para Ansible), um arquivo CSV, dicionários e listas em Python ou em outro local.

Em seguida, seu código do “primeiro” lerá os detalhes do “segundo” para concluir o projeto.

A “fonte da verdade” é essa segunda coisa. É simplesmente os detalhes que são o estado desejado da rede. Todo projeto tem uma “Fonte da verdade”, mesmo que você não pense dessa maneira. Existem muitas ferramentas / formatos diferentes que sua fonte de verdade pode levar.

As fontes simples de verdade incluem arquivos YAML e CSV e são ótimas para pequenos projetos e quando você inicia a automação. No entanto, muitos engenheiros e organizações geralmente chegam a um ponto em sua jornada de automação em que essas opções simples não estão mais atendendo às suas necessidades. Pode ser por causa da enorme quantidade de dados que se torna pesada. Ou talvez sejam as relações entre diferentes tipos de dados. Ou pode ser que toda a equipe não se sinta à vontade trabalhando em texto bruto para obter suas informações.

Quando as opções baseadas em texto não estão mais atendendo às necessidades, as organizações podem recorrer a aplicativos com mais recursos para atuar como sua Fonte da verdade. Aplicativos como o Gerenciamento de Infraestrutura de Data Center (DCIM) e o Gerenciamento de Endereço IP (IPAM) podem definitivamente desempenhar o papel da Fonte da Verdade. Mas há uma diferença fundamental no uso de uma ferramenta DCIM / IPAM como uma fonte de verdade de automação em relação à forma como tradicionalmente as usamos.

Leia Também  Rede definida por software versus virtualização de funções de rede - diferenças e benefícios

No passado (antes da automação), os dados e informações nessas ferramentas eram frequentemente inseridos depois que uma rede era projetada, construída e configurada. Os dados do DCIM e do IPAM eram uma representação de “melhor esforço” da rede, normalmente feita de má vontade por engenheiros que estavam ansiosos para avançar para o próximo projeto. E se formos honestos conosco, provavelmente nunca confiámos nos dados de qualquer maneira. A única “Fonte da Verdade” real para como a rede foi configurada foi a própria rede. Deseja saber qual era a configuração desejada para um switch específico? Bem, entre nele e veja.

Com a automação de rede orientada pela Fonte da Verdade, giramos o caminho antigo de cabeça para baixo. Os detalhes do primeiro local sobre a rede são inseridos não na CLI de um roteador, mas na ferramenta IPAM / DCIM. Planejando os endereços IP para cada interface do roteador – atualize a Source of Truth. Criando a lista de VLANs para um site específico – atualize a Source of Truth. Adicionando uma nova rede a um site existente – atualize a Source of Truth.

O motivo da alteração é que o código que você executa para criar a configuração de rede lê os dados de cada dispositivo específico da Fonte da Verdade no tempo de execução. Se os dados não estiverem na sua ferramenta DCIM / IPAM, a automação não funcionará. Ou, se os dados não estiverem corretos na ferramenta DCIM / IPAM, a automação gerará uma configuração incorreta.

Também é importante notar agora que uma fonte da verdade pode ser usada como parte dos testes de validação e integridade da rede, bem como para a configuração. Escrevendo um caso de teste de rede com pyATS e Genie para verificar se todas as suas interfaces estão configuradas corretamente? Bem, como você sabe o que é “correto”? Você leu a partir da sua fonte de verdade. Chamo isso de “Validação de rede orientada pela fonte da verdade” e abordarei isso mais especificamente em uma futura postagem no blog.

Exposição suficiente, vamos ver isso em ação.

A fonte da verdade que usamos na DevNet Sandbox para a maioria das informações é a Netbox. O Netbox é uma ferramenta de código aberto DCIM / IPAM desenvolvida originalmente pela equipe de automação de rede da Digital Ocean para suas próprias necessidades, e tem sido popular entre muitos engenheiros e empresas que procuram uma ferramenta própria. Para mergulhar na Netbox, confira este vídeo em que os proprietários do projeto, Jeremy Stretch e John Anderson, discuta-o no TechField Day.

Suponhamos que precisamos adicionar uma nova rede ao nosso principal ambiente de administrador interno na Sandbox com as seguintes informações básicas.

  • O nome da rede será demo-sourceoftruth
  • Ele precisará de um prefixo IP atribuído a ele do espaço IP apropriado
  • Ethernet 1/3 no interruptor sjcpp-leaf01-1 precisa ser configurado como uma porta de acesso para esta rede

A automação para fazer a configuração real da VLAN, SVI, configuração da interface, etc. já está concluída (eu cobri isso na Parte 1 da Automação Baseada em Serviços de Rede – A Experiência), o que preciso fazer é atualizar a Fonte da Verdade que conduzirá a automação. Isso envolve as seguintes etapas:

  1. Criando um novo objeto VLAN
  2. Alocar um prefixo disponível e atribuir à nova VLAN
  3. Atualizando os detalhes da porta Ethernet 1/33 para ser uma porta de acesso nesta VLAN

Nota: Você pode clicar nas imagens da tela a seguir para ampliar para facilitar a visualização.

Etapa 1: Criando um Novo Objeto VLAN

Inicio no Netbox na visualização Inquilino do nosso ambiente de administrador. A partir daqui, posso visualizar facilmente todos os detalhes do DCIM e do IPAM desse ambiente.

Visualização de inquilino da Netbox

Clico em VLANs para ver a lista atual de VLANs.

Visualização de VLANs

A coluna “Grupo” representa o grupo de VLAN no Netbox – que é uma maneira de organizar VLANs que fazem parte do mesmo domínio de comutação em que um ID de VLAN específico tem significado. Essa nova rede estará no grupo “Interno”. Clico em “Interno” em qualquer uma das VLANs para pular rapidamente para essa parte do Netbox para encontrar um ID de VLAN disponível para uso.

cupom com desconto - o melhor site de cupom de desconto cupomcomdesconto.com.br

Grupo VLAN

Vejo que existem 4 VLANs disponíveis entre 25 e 30 e clico na caixa verde para adicionar uma nova nesse espaço.

Nova VLAN

Eu forneço o novo nome para esta rede e indico que sua função será para “Sistemas Sandbox”. Como essa nova rede fará parte do inquilino administrador, seleciono o grupo e o inquilino adequados nas listas suspensas. A Netbox suporta a criação de campos personalizados para os dados necessários e criamos um campo chamado “Camada 3 ativada no Switched Fabric” para indicar se os SVIs devem ser configurados para uma rede. Nesse caso, isso é verdade. Depois de fornecer os detalhes, clique em “Criar” para criar esta nova VLAN.

Etapa 2: Alocando um prefixo disponível e atribuindo à nova VLAN

O Netbox é um IPAM com todos os recursos, por isso, vamos alocar um prefixo para a VLAN.

Começo na Supernet para redes administrativas neste site, 10.101.0.0/21, para encontrar um prefixo disponível.

Prefixos

Clico no intervalo Disponível, para ir para a interface “Adicionar um novo prefixo”.

Novo prefixo

Começo atualizando o Prefixo para o tamanho adequado que desejo, escolhendo a Função (que corresponde à função da VLAN), fornecendo uma boa descrição para que as pessoas saibam o que é isso. Em seguida, escolho a nova VLAN que acabamos de criar para associar esse prefixo às opções suspensas e de pesquisa fornecidas na interface do usuário. Por fim, escolho o inquilino Admin e clico em “Criar”

Agora, se eu voltar e examinar as VLANs associadas ao administrador inquilino, posso ver nossa nova VLAN na lista com o prefixo alocado.

Visualização de VLANs

Etapa 3: Atualizando os detalhes da porta Ethernet 1/3 para ser uma porta de acesso nesta VLAN

A etapa final no Netbox é indicar as interfaces físicas do switch que terão dispositivos conectados a essa nova VLAN.

Navego no Netbox para a página de detalhes do dispositivo para o comutador relevante. Na parte inferior da página estão todas as interfaces no dispositivo. Encontro a interface Ethernet 1/3 e clico no botão “Editar”.

Visualização do dispositivo

Atualizo a configuração da interface com uma Descrição apropriada, defino o Modo 802.1Q como Acesso e seleciono nossa nova VLAN como a VLAN sem etiqueta para a porta. Em seguida, clique em “Atualizar” para salvar as alterações.

Interface de Edição

Aplicando a nova configuração de rede

Com nossa fonte de verdade agora atualizada com as novas informações de rede, precisamos simplesmente de nossa automação de rede para ler esses dados e configurar a rede. Há muitas maneiras de fazer isso, incluindo uma opção totalmente automatizada, na qual um webhook da Netbox inicia a automação. Em nosso ambiente, estamos adotando a automação de rede em etapas, à medida que construímos experiência e confiança. Nosso status atual é que executamos a automação para processar os dados da Source of Truth para atualizar a configuração da rede manualmente.

Lembrete de que já executei nossa automação nas postagens de visualização

Quando executo a automação para atualizar a configuração de rede com as novas informações da Fonte da Verdade, aqui estão as alterações na configuração de vlan-tenant para o nosso ambiente de administrador.

[email protected](config)# load merge nso_generated_configs/vlan-tenant_admin.xml
Loading.
1.78 KiB parsed in 0.00 sec (297.66 KiB/sec)

[email protected](config)# show configuration
vlan-tenant admin
  network demo-sourceoftruth
    vlanid 26
    network 10.101.1.0/28
    layer3-on-fabric true
    connections switch-pair sjcpp-leaf01
      interface 1/3
      description "Demonstration VLAN for Blog - Interface Config"
      mode access

Aqui você pode ver a nova rede sendo criada, juntamente com o ID da VLAN, o prefixo e até as configurações da interface física. Todo esse detalhe foi extraído diretamente da Netbox pelo nosso processo de automação.

Leia Também  Como os catalisadores escalam | A experiência completa dos catalisadores em 4K!

E se você deseja ver a configuração final da rede que será aplicada à rede após o processamento dos modelos em nosso serviço de rede pela NSO, aqui está ela.

    device {
        name sjcpp-leaf01-1
        data vlan 26
              name demo-sourceoftruth
             !
             interface Vlan26
              no shutdown
              vrf member admin
              ip address 10.101.1.2/28
              no ip redirects
              ip router ospf 1 area 0.0.0.0
              no ipv6 redirects
              hsrp version 2
              hsrp 1 ipv4
               ip 10.101.1.1
               preempt
               priority 110
              exit
             exit
             interface Ethernet1/3
              switchport mode access
              switchport access vlan 26
              no shutdown
              description Demonstration VLAN for Blog - Interface Config
              mtu 9216
             exit
    }
    device {
        name sjcpp-spine01-1
        data vlan 26
              name demo-sourceoftruth
             !
    }

Nota: O serviço também atualiza o vCenter para criar um novo grupo de portas para a vlan, bem como para o Cisco UCS, mas só estou mostrando aqui a configuração de rede típica.

Espero que isso lhe dê uma idéia melhor sobre como uma Fonte da Verdade se encaixa nos projetos de automação de rede e como uma ferramenta como o Netbox fornece esse recurso importante para as empresas.

Mas uma coisa antes de encerrar completamente … Depois de falar ou mostrar algo assim aos engenheiros, muitas vezes ouço comentários como “A Netbox parece legal, mas eu poderia ter feito a mesma coisa com 10 linhas de YAML”. E esse é um ponto totalmente válido. O salto para uma ferramenta como o Netbox para sua fonte de verdade a partir das opções mais simples baseadas em texto tem um custo em tempo de instalação, complexidade e esforço para sua equipe. Nem todas as equipes precisam fazer a alteração, mas, pela minha experiência, muitas equipes acabam superando os arquivos YAML à medida que seus projetos e habilidades de automação amadurecem. Meu objetivo neste post foi fornecer algumas informações úteis e um exemplo do que pode ser feito quando você chegar a esse ponto.

Se você quiser saber mais sobre como a equipe do DevNet Sandbox está adotando a automação de rede e outras práticas do NetDevOps, junte-se a mim em Barcelona para o DEVNET-1488: Como o DevNet Sandbox construiu uma rede automatizada de datacenter em menos de 6 meses ou procure para a gravação após o evento no catálogo do Cisco Live On Demand. Você já pode encontrar a sessão do CLUS2019 em que discuti alguns de nossos planos que levaram ao recente projeto que estou cobrindo em Barcelona.

Alguns outros ótimos recursos incluem:

Agora é sua vez. O que você usa para uma fonte de verdade? Deixe-me saber nos comentários ou envie-me um ping no Twitter em hfpreston. Falo com você em breve!

Compartilhar:



cupom com desconto - o melhor site de cupom de desconto cupomcomdesconto.com.br